#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)( # start of capture group 1" & @CRLF & _
"% # literal "%"" & @CRLF & _
"(?: # first option" & @CRLF & _
"(?:[-+0 #]{0,5}) # optional flags" & @CRLF & _
"(?:\d+|\*)? # width" & @CRLF & _
"(?:\.(?:\d+|\*))? # precision" & @CRLF & _
"(?:h|l|ll|w|I|I32|I64)? # size" & @CRLF & _
"[cCdiouxXeEfgGaAnpsSZ] # type" & @CRLF & _
") | # OR" & @CRLF & _
"%%) # literal "%%""
Local $sString = "Worker name is %s and id is %d" & @CRLF & _
"That is %i%%" & @CRLF & _
"%c" & @CRLF & _
"Decimal: %d Justified: %.6d" & @CRLF & _
"%10c%5hc%5C%5lc" & @CRLF & _
"The temp is %.*f" & @CRLF & _
"%ss%lii" & @CRLF & _
"%*.*s | %.3d | %lC | %s%%%02d" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")