import re
regex = re.compile(r"""
( # start of capture group 1
% # literal "%"
(?: # first option
(?:[-+0 #]{0,5}) # optional flags
(?:\d+|\*)? # width
(?:\.(?:\d+|\*))? # precision
(?:h|l|ll|w|I|I32|I64)? # size
[cCdiouxXeEfgGaAnpsSZ] # type
) | # OR
%%) # literal "%%"
""", flags=re.VERBOSE)
test_str = ("Worker name is %s and id is %d\n"
"That is %i%%\n"
"%c\n"
"Decimal: %d Justified: %.6d\n"
"%10c%5hc%5C%5lc\n"
"The temp is %.*f\n"
"%ss%lii\n"
"%*.*s | %.3d | %lC | %s%%%02d\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")