const regex = new RegExp('^(?=.*\\d.*\\d)[0-9A-Za-z!@#$%*]{8,}$', 'gm')
const str = `aaaa
1111
aaaaaaaaaa
aaaaaaaaaa1
aaaaaaaaaaa1aaa1
aaaaaaaaaaa##1
aaaaaaaaaa##1aaa1
############11
^- Actually your requirement :p`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}