import Foundation
let pattern = ##"^(?=.*\d.*\d)[0-9A-Za-z!@#$%*]{8,}$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #############"""
aaaa
1111
aaaaaaaaaa
aaaaaaaaaa1
aaaaaaaaaaa1aaa1
aaaaaaaaaaa##1
aaaaaaaaaa##1aaa1
############11
^- Actually your requirement :p
"""#############
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)