using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(alert\((.*)\);)";
string input = @"alert(123); var hello = 0;
console.log(hello);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}