package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(alert\((.*)\);)`)
var str = `alert(123); var hello = 0;
console.log(hello);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}