package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\.]\s[A-Z][a-z]+)`)
var str = `CACA mou et Pipi dans ta Bouche sale con de Juif.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}