$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[@#$%^&+=]).{8,25}$/m';
$str = 'asb12A@1
asb12A@1aaaaaaaaaaaaaaaaa
asb12A@
asb12A@1111dasdsadsadsdsdd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);