import re
regex = re.compile(r"^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[@#$%^&+=]).{8,25}$", flags=re.MULTILINE)
test_str = ("asb12A@1\n"
"asb12A@1aaaaaaaaaaaaaaaaa\n"
"asb12A@\n"
"asb12A@1111dasdsadsadsdsdd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")