re = /(?s)(?!.*?start)^(\w+)\s(\w+)\s(\w+)(?=.*?end)/m
str = 'abcd 123 123
start
abcd 123 123
abcd 123 123
abcd 123 123
end
abcd 123 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end