# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[[:digit:]]+ Bytes / /;t' <<< "200000 Bytes [250 GB]"