$re = '/^[A-Za-z]{3}[0-9]{2}$/m';
$str = 'asd23
asd23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);