$re = '/(?<!})({((?<type>\D):)?(?<name>[a-zA-Z_-ÿ][a-zA-Z0-9_-ÿ]+)})(?!{)/';
$str = '/home/{i:id}{s:noVar}/{m:varName}/{s:someOther}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);