re = /(?<!})({((?<type>\D):)?(?<name>[a-zA-Z_-ÿ][a-zA-Z0-9_-ÿ]+)})(?!{)/
str = '/home/{i:id}{s:noVar}/{m:varName}/{s:someOther}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end