$re = '/(?:{(?:[a-zA-Z]:)?[a-zA-Z_]\w*}){2,}(*SKIP)(*F)|({(?:(?<type>[a-zA-Z]):)?(?<name>[a-zA-Z_]\w*)})/';
$str = '/home/{i:id}{s:noVar}/{m:varName}/{s:someOther}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);