re = /(?:{(?:[a-zA-Z]:)?[a-zA-Z_]\w*}){2,}(*SKIP)(*F)|({(?:(?<type>[a-zA-Z]):)?(?<name>[a-zA-Z_]\w*)})/
str = '/home/{i:id}{s:noVar}/{m:varName}/{s:someOther}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end