import Foundation
let pattern = #"(?(DEFINE)(?<hours>[0-2]\d{1})(?<minutes>[0-5]\d{1})(?<seconds>(?&minutes))(?<milliseconds>\d{3})(?<separator>\-\-\>)(?<timecode>((?&hours):)?(?&minutes):(?&seconds)\.(?&milliseconds)))^(?<start>(?&timecode))\ {1,}-->\ {1,}(?<end>(?&timecode))(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"00:59:59.100 --> 00:00:00.000asdasdasdkjsdkjfhsdkjgfhdkfjhglaksjd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)