#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+@\w{1,63}\.[a-z]{3}"
Local $sString = "abc" & @CRLF & _
"" & @CRLF & _
"testing@longName63IstheMaxforthisthisismorethanthatnotsurewhenisittoomuch.com" & @CRLF & _
"" & @CRLF & _
"tdedonno@juno.com" & @CRLF & _
"" & @CRLF & _
"tdedonno@saddleback.edu" & @CRLF & _
"" & @CRLF & _
"problem_123@nonStandard_.edu" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")