// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+@\w{1,63}\.[a-z]{3}").unwrap();
let string = "abc
testing@longName63IstheMaxforthisthisismorethanthatnotsurewhenisittoomuch.com
tdedonno@juno.com
tdedonno@saddleback.edu
problem_123@nonStandard_.edu
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}