using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(""(?<name>\w+Message)"",?(?<messages>(?:""\w+Message"",?)*),function\([\w,]*\){.*?}\)";
string input = @"(""aaMessage"",""firstMessage"",""sdfsdfMessage"",function(e){})";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}