package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sUi)\("(?<name>\w+Message)",?(?<messages>(?:"\w+Message",?)*),function\([\w,]*\){.*?}\)`)
var str = `("aaMessage","firstMessage","sdfsdfMessage",function(e){})`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}