$re = '`\b\d+/\d+/\d+ +(?:1[0-2]|0?[1-9]):[0-5][0-9] ?[ap]m(?= +\d)`mi';
$str = 'of Los Angeles 12/19/2018 11:39 AM She
as a Unit 1/18/2019 8:30 AM 4 1.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);