import re
regex = re.compile(r"\b\d+/\d+/\d+ +(?:1[0-2]|0?[1-9]):[0-5][0-9] ?[ap]m(?= +\d)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("of Los Angeles 12/19/2018 11:39 AM She\n"
"as a Unit 1/18/2019 8:30 AM 4 1.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")