package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<Text>.+)\s+:(?<Number>\d)|(?<Text>.+)`)
var str = `foo 6
foo :6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}