$re = '/(?<Text>.+)\s+:(?<Number>\d)|(?<Text>.+)/Jm';
$str = 'foo 6
foo :6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);