$re = '/^(([\'"])|\()(.*)(?(?=\2)(\2)|(\)))$/m';
$str = '(hello)
\'hello\'
"hello"
(hello (world))
"hello \'world\'"
(hello "world")
"hello (world)"
""
\'\'
()
\'"hello world\'
"\'hello world"
((
))
\'"
\'"
(hello(
)hello)
"hello\'
"hello world\'
\'hello world"
\'"hello world\'"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);