re = /^((['"])|\()(.*)(?(?=\2)(\2)|(\)))$/m
str = '(hello)
\'hello\'
"hello"
(hello (world))
"hello \'world\'"
(hello "world")
"hello (world)"
""
\'\'
()
\'"hello world\'
"\'hello world"
((
))
\'"
\'"
(hello(
)hello)
"hello\'
"hello world\'
\'hello world"
\'"hello world\'"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end