using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\(";
string input = @"There is a sad face somew:(here inside this text.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}