package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s):\(`)
var str = `There is a sad face somew:(here inside this text.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}