#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:https?:\/\/)?(?:www\.)?example\.[a-zA-Z0-9./]+$"
Local $sString = "example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"http://example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"example.com/exam1/exam.php" & @CRLF & _
"example.com/exam"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")