$re = '/^(?:https?:\/\/)?(?:www\.)?example\.[a-zA-Z0-9./]+$/im';
$str = 'example.com
www.example.com
http://example.com
https://www.example.com
example.com/exam1/exam.php
example.com/exam';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);