#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)http:\/\/(.*)\/(.*)"
Local $sString = "http://static.infoconcert.com/media/artiste/details/JOHNNY_HALLYDAY_2015_2016_120x150.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")