$re = '~[[:punct:]]++((?<=\+)(?<=[^+]\+))~';
$str = 'Hello+ World+ C+ C++ C';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;