import Foundation
let pattern = #"[[:punct:]]++((?<=\+)(?<=[^+]\+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hello+ World+ C+ C++ C"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)