package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:(\w+)\/|([a-zA-Z_-]+))`)
var str = `Gi0/0/0/0
BVI10
BVI 10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}