$re = '/^(?:(\w+)\/|([a-zA-Z_-]+))/im';
$str = 'Gi0/0/0/0
BVI10
BVI 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);