use strict;
my $str = 'Салатник 600 мл h= 4.7 см 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл
Салатник 600 мл V= 4.7 л 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл
Салатник 600 мл h= 4.7 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл
Салатник 600 мл h= 4.7 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл
Салатник 19.3см d=19.3 см 600 мл h= 4.7см 19.3 см d 19.3 см D=19.3 600 мл';
my $regex = qr/d=?\s*\d+\.\d+\s*(?:см)?|(?<!h|h=\s)\d+\.\d+\s*(?:см)/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}