# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"d=?\s*\d+\.\d+\s*(?:см)?|(?<!h|h=\s)\d+\.\d+\s*(?:см)"
test_str = ("Салатник 600 мл h= 4.7 см 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл\n"
"Салатник 600 мл V= 4.7 л 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл\n"
"Салатник 600 мл h= 4.7 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл\n"
"Салатник 600 мл h= 4.7 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл\n"
"Салатник 19.3см d=19.3 см 600 мл h= 4.7см 19.3 см d 19.3 см D=19.3 600 мл")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.