$re = '/\/\*([a-zA-Z0-9]+)_START\*\/(.*?)\/\*\1_END\*/ms';
$str = '/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);