re = /\/\*([a-zA-Z0-9]+)_START\*\/(.*?)\/\*\1_END\*/m
str = '/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end