using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*([a-zA-Z0-9]+)_START\*\/(?=(.*?)\/\*\1_END\*)";
string input = @"/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}