re = /\/\*([a-zA-Z0-9]+)_START\*\/(?=(.*?)\/\*\1_END\*)/m
str = '/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end