package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[dr](.+?)-(\d+)\[/dr]`)
var str = `[dr]my name here-25[/dr]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}