$re = '~\[dr](.+?)-(\d+)\[/dr]~';
$str = '[dr]my name here-25[/dr]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);