#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^Node-path: |\G)\S+\K\h+"
Local $sString = "..." & @CRLF & _
"pla bla bli" & @CRLF & _
"" & @CRLF & _
"Node-path: branches/BU ILD/ml_cf/syst em/Translation/TranslationManager.class.php " & @CRLF & _
"Node-kind: file" & @CRLF & _
"Node-action: change" & @CRLF & _
"Text-delta: true" & @CRLF & _
"...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")