re = /(?:^Node-path: |\G)\S+\K\h+/m
str = '...
pla bla bli
Node-path: branches/BU ILD/ml_cf/syst em/Translation/TranslationManager.class.php
Node-kind: file
Node-action: change
Text-delta: true
....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end