#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)^\bgeneral( #[0-9])?(.*?)^\s*$"
Local $sString = "General" & @CRLF & _
                "Complete name                            : C:\Projects\Foray\MediaEngine\SampleMedia\flv\small.flv" & @CRLF & _
                "Format                                   : Flash Video" & @CRLF & _
                "File size                                : 296 KiB" & @CRLF & _
                "Duration                                 : 5s 560ms" & @CRLF & _
                "Overall bit rate mode                    : Variable" & @CRLF & _
                "Overall bit rate                         : 436 Kbps" & @CRLF & _
                "Writing application                      : Lavf52.103.0" & @CRLF & _
                "" & @CRLF & _
                "Video" & @CRLF & _
                "Format                                   : Sorenson Spark" & @CRLF & _
                "Codec ID                                 : 2" & @CRLF & _
                "Duration                                 : 5s 560ms" & @CRLF & _
                "Bit rate                                 : 781 Kbps" & @CRLF & _
                "Width                                    : 320 pixels" & @CRLF & _
                "Height                                   : 240 pixels" & @CRLF & _
                "Display aspect ratio                     : 4:3" & @CRLF & _
                "Frame rate mode                          : Constant" & @CRLF & _
                "Frame rate                               : 25.000 fps" & @CRLF & _
                "Bit depth                                : 8 bits" & @CRLF & _
                "Bits/(Pixel*Frame)                       : 0.407" & @CRLF & _
                "Stream size                              : 530 KiB" & @CRLF & _
                "" & @CRLF & _
                "Audio" & @CRLF & _
                "Format                                   : MPEG Audio" & @CRLF & _
                "Format version                           : Version 1" & @CRLF & _
                "Format profile                           : Layer 3" & @CRLF & _
                "Codec ID                                 : 2" & @CRLF & _
                "Codec ID/Hint                            : MP3" & @CRLF & _
                "Duration                                 : 5s 512ms" & @CRLF & _
                "Bit rate mode                            : Variable" & @CRLF & _
                "Bit rate                                 : 63.8 Kbps" & @CRLF & _
                "Channel(s)                               : 1 channel" & @CRLF & _
                "Sampling rate                            : 44.1 KHz" & @CRLF & _
                "Compression mode                         : Lossy" & @CRLF & _
                "Stream size                              : 42.9 KiB (14%)" & @CRLF & _
                "" & @CRLF & _
                "" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")