package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^=]+)=([^=]+)$`)
var str = `5 + 4 * X + X^2= X^2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}