$re = '/^([^=]+)=([^=]+)$/';
$str = '5 + 4 * X + X^2= X^2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);