package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|\,{1,})(foobar)(?:$|\,{1,})`)
var str = `foobar,sdf,sdffoobar,foobar,foobarads,foobar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}